FAQ

How can I send the bug report?

Please send a bug report to astah-support@change-vision.com with the following log files.

  • env.log

  • trace.log

(astah* System Safety) The log files are stored in USER_HOME\.astah\systemsafety\.

(astah* SysML) The log files are stored in USER_HOME\.astah\sysml\.

How can I increase the performance of Astah ?

The performance level of Astah depends on the RAM capacity of your machine.

Try the following methods to improve the performance:

Turn off the mouse cursor tracing option.

In some environments, this option may slower the drawing on the diagram.

Tune the garbage collection settings of Java.

Change the heap size. It depends on your environment and the maximum size of “-Xmx” is 1024m on the 32bit machine.

Example)

-Xms16m

-Xmx512m

Windows

Run the text editor as an administrator and modify the configuration file.

(astah* System Safety) The configuration file is located in the installation folder astahsystemsafety.l4j.ini.

(astah* SysML) The configuration file is located in the installation folder astahsysml.l4j.ini.

Mac

Open a terminal and execute the following command

Example of rewriting the maximum heap size to 2048m

(astah* System Safety) defaults write com.change-vision.astahsystemsafety /com/change-vision/astahsystemsafety/ -dict-add JVMOptions/ ‘{ “Xmx” = “-Xmx2048m” }’

(astah* SysML) defaults write com.change-vision.astahsysml /com/change-vision/astahsysml/ -dict-add JVMOptions/ ‘{ “Xmx” = “-Xmx2048m” }’

Astah is slow to operate

If several diagrams and tables are opened in the Diagram Editor, the operation of Astah becomes slow. Please close the unused diagrams and tables.

How can I use the different Java VM?

  1. Copy the jre folder of the installed JDK in your machine.

  2. Replace the jre folder in the Astah installed folder to the copied jre folder.

  3. Run Astah.

Note) As shown in System Requirements , the operation is not guaranteed except for the included Java.

Can I run Astah on Linux or macOS?

Astah is compatible with Windows and macOS. Linux is not supported.

Can I paste diagrams in Microsoft Word, Excel or PowerPoint?

Diagrams can be exported as an image file with BMP, PNG, EMF and SVG formats. Go to [File] - [Export Image] in the main menu and save the image file. And then, insert it into Microsoft Word, Excel and PowerPoint.

Or, select Diagram Elements on the Diagram and go to [Edit]-[Copy to Clipboard] in the Main Menu.

Vector (EMF and SVG) format keeps clearer image than the raster format so that it does not degrade by scaling the pasted image.

Note) Ungrouping images in Word, Excel are not supported.

Can I export tables to Excel?

Each table can be individually exported from [Rxport to Excel] button on the upper right corner of the table or from [File] - [Export ] menu.

(astah* System Safety) To export all the STAMP/STPA tables at once, go to [File] - [Export] - [STAMP/STPA Tables to Excel].

(astah* System Safety) (astah* SysML) To export Requirement table, go to [File] - [Export] - [SysML Requirement Table to Excel].