You can import diagrams you created using Astah GSN into Astah System Safety (ver7.0 and later).
This allows you to transfer your data from Astah GSN to Astah System Safety to use the advanced functionalities of Astah System Safety.
※ You cannot transfer the data back from Astah System Safety to Astah GSN.

section divider

Import Astah GSN files

  1. Go to [Tools] – [GSN] – [Import Astah GSN Project (.agml)]
    Import Astah GSN files

  2. Choose the .agml file you want to import

  3. If some models were not imported completely due to the restrictions below, you will get a window explaining the details about them. Please read them through and click [OK] to complete the import.
    If you did not see this window, that means loading the .agml file completed successfully.
    Astah GSN Import Result

Status

Description

INFO
This indicates that the model was imported but some of its properties were changed or lost.
WARNING
This indicates that the model was not imported.
ERROR
This indicates that the project import completely failed.

You can also load from [File] – [Open] menu

You can also load the Astah GSN files directly from [File] – [Open] menu.
If you are on Windows, change the [Files of type] to enable you to choose the Astah GSN files (.agml) first.

section divider

Notes

The following models and objects will not be imported.

  • Unsupported Mini-icons
  • Nested models (e.g: A Goal will not be imported in the case below)
    Nested models in Astah GSN