View Question

Astah drawing bug

I just installed Astah Professional to my Arch Linux computer. About a year ago I used version 7.0.0 to create a model for an assignment without any flaws. However, with both versions 7.0.0 and 7.1.0 (and both Oracle JDK 8b121 and OpenJDK 8b121) I now get a drawing bug.

When opening the .asta file I used last year (or trying to create a new model), whenever I open a class diagram everything gets repeated every 100x100 pixels or so. When using the scrollbars every such box scrolls independently, creating this weird output. When opening the menus and hovering over them the disappeared part gets drawn correctly, until I hover with the mouse over the model window, when everything gets redrawn incorrectly again. Only when minimizing the class diagram window and reopening it again, the output looks correctly, until I move my mouse over the window and the wrong output shows up again.

Has anyone experienced this before?

Product: Astah Professional

It turns out that the bug only appears when starting Astah Professional from a terminal (xterm or rxvt-unicode, it doesn't matter which). However, when starting Astah from the toolbar in my window manager (IceWM) everything seems to be alright.

Hi Marcel,

Thank you for the detailed description of the drawing problem in Astah.

Could you try to use another Look & Feel? It may solve the problem. (Go to [View] - [Look & Feel] in the main menu)

If it does not work, please use the toolbar in your window manager to start Astah for now. We will look into the cause of the problem.

Thanks, Midori

Answer Question

This content has the following tags:

bugdrawingscreen