Astah System Safety supports XMI import and export of SysML models which makes the models compatible with other tools such as Cameo Systems Modeler.

section divider

Import from Cameo Systems Modeler

You can import the project files generated by Cameo Systems Modeler of Dassault Systèmes’ S.E. to Astah via XMI.
Go to [Tools] – [UML/SysML] – [Open XMI] – [Cameo SysML XMI(.mdxml)] or [Cameo SysML (.mdzip)] from the Main Menu.
Import Cameo XMI

Currently, Astah System Safety can import the following diagram types from Cameo Systems Modeler.

  • Requirement Diagram
  • Block Definition Diagram
  • Internal Block Diagram
  • Parametric Diagram
  • Activity Diagram
  • Sequence Diagram

To learn more details on compatible data, please go to [Help] – [Reference Manual] and read [Import from Cameo Systems Modeler] page.

section divider

Export SysML models to XMI

There are three types of XMI you can export models in Astah System Safety.

  1. OMG XMI 2.5 (.xmi)
  2. Cameo SysML XMI (.mdxml)
  3. Obfuscated XMI (for bug report)
section divider

OMG XMI 2.5 (.xml)

You can export UML/SysML diagrams and models to XMI 2.5.
[Tools] – [UML/SysML] – [Export to XMI] – [OMG XMI 2.5(.xml)].
SysML XMI Export

section divider

Cameo SysML XMI

You can export SysML models to XMI file (.mdxml) that is compatible with Cameo Systems Modeler of Dassault Systèmes SE.

How to export

  1. Go to [Tools] – [UML/SysML] – [Export to XMI] – [Cameo SysML XMI(.mdxml)].
    Cameo SysML XMI Export

  2. Make sure you choose [Cameo SysML XMI Files (.mdxml)] as its file type and hit [Save].
section divider

How to import to Cameo Systems Modeler

You should be able to import this .mdxml file into Cameo Systems Modeler version 18.5 or later from [File]-[Open Project] or [File]-[Import From]-[Other MagicDraw Project]. (Refer to the user’s manual of Cameo for details.).
We confirm that it works with Cameo Systems Modeler version 18.5 and 19.0.

section divider

Compatible models

Currently, the following SysML models can be exported to Cameo Systems Modeler via XMI.

Diagrams
Block Definition Diagram, Internal Block Diagram, Parametric Diagram, Requirement Diagram(*1), UseCase Diagram(*2),
Activity Diagram(*3), Statemachine Diagram(*4)and Sequence Diagram
Models
Packages, Blocks, InterfaceBlocks, Constraint Blocks, Value Type, Interface, Unit, QuantityKind, Ports, Full Ports, Proxy Ports, Nest, Generalization, Associations, Dependencies, Realizations, Usage Dependencies, Notes
Properties
Parts, References, Values, Flows, Constraints, Constraint Parameters
section divider

Incompatible models

Currently, the following SysML models can NOT be exported to Cameo Systems Modeler via XMI.

Table
Requirement Table
Models
Duration Constraint, Time Constraint in Sequence Diagram
Objects
Text, Text Box, Rectangles, lines, free shapes, highlighters and inserted images
section divider

Notes

  • The appearance of model elements is different between Astah System Safety and Cameo Systems Modeler.
  • Assembly connectors will not be imported to Cameo Systems Modeler. It will be imported as a Requirement Interface and Provided Interface.
  • Model elements in SysML’s standard library will not be imported to Cameo Systems Modeler.
section divider

Requirement Diagram (*1)

  • When you open the imported Requirement diagram, both ID and Text will appear inside each requirement.
section divider

UseCase Diagram (*2)

When you open the imported UseCase diagram,
– all the Actors will be represented in an actor icon instead of a rectangle and
– all the UseCases will have its name inside

section divider

Activity Diagram (*3)

  • The size of the diagram frame and the partition may change when importing to Cameo.
  • If there are any model elements outside partitions, you may see an alert when importing via .mdxml.
  • The end of partitions may not be closed in the imported diagram.
  • Any arrows inside Input/Output pins will not be displayed in the imported diagrams.
section divider

Statemachine Diagram (*4)

  • Vertical Regions will be converted to Horizontal ones after import.
section divider

Obfuscated XMI (for bug report)

Astah support may ask you to provide your .axmz file along with your bug report in case the log file did not contain enough information to find the cause.

If the .axmz files contain any confidential information, you can obfuscate the data, so all the model names would be replaced with meaningless characters and numbers.

  1. Open your .axmz file
  2. Go to [Tools] – [Correct Model] – [Save as Obfuscated Project [For Bug Report]].
    Obfuscated XMI

  3. Save the .xml file and send it to Astah Support.