Block Definition Diagram in the Arc Dark Contrast (Material) theme
Turn on dark theme (Material)
To apply a Material dark theme, go to [View] – [Look & Feel] – [Dark Themes (Material)] in the main menu and choose a theme. Material dark themes are available in:
Astah Professional, Astah UML and Astah Viewer version 9.0 and later
Astah SysML and Astah System Safety version 8.0 and later
Background of Diagram Editor
Themes do not change the background color of the Diagram Editor. To match it to a dark theme, change it here:
Astah Professional and Astah UML: [Tools] – [System Properties] – [Diagram Editor] – [Background color]
Astah SysML and Astah System Safety: [Tools] – [System Properties] – [Basic] – [Diagram Editor] – [Background color]
Pre-installed Themes
Astah comes with nearly 70 pre-installed themes. This page previews each Material dark theme; for our picks, see the 8 best themes we recommend.