Pricing and Discounts

section divider

Licensing

  • How can I access my license file?
    1. Log into CV Members site and click [License Management].
    2. Choose [Download this license key] and click [Next].
      Download Astah System Safety License
  • How can I cancel my subscription?

    There are two ways to cancel your ongoing subscription.

    Option1:
    You will receive an email from our online store – mailer@fastspring.com 10 days before your subscription license expires. To cancel, access the link in the email and press [Cancel Subscription].


    Canceling on-going subscription


    Option2:
    Please submit a cancellation request from this form.

section divider

Setup and Uninstall

  • How can I install Astah System Safety?
  • How Can I Change the Display Language of Astah System Safety to Japanese?

    Astah System Safety supports both English and Japanese languages. It automatically launches in English if your PC’s language and regional settings are not set to Japanese. Here’s how you can switch the language to Japanese:

    For Windows Users:

    1. Close Astah System Safety if it is running.
    2. Open the astahsystemsafety.l4j.ini file in the Astah System Safety Installation folder with a text editor.
    3. Add the following, then save the file.
      -Duser.language=ja
      -Duser.country=JP
    4. Launch Astah System Safety. It should now start in Japanese.

     

    For Mac users:

    1. Close Astah System Safety if it is running
    2. Open Terminal and execute the following command.
      %defaults write com.change-vision.astah.astahsystemsafety /com/change-vision/astah/astahsystemsafety/ \ -dict-add JVMOptions/ '{ "language" = "-Duser.language=ja"; "country" = "-Duser.country=JP"; }'
    3. Start Astah System Safety, and it will be in Japanese.
  • How can I uninstall Astah?

    You can uninstall Astah by following the step below if you decided not to use Astah after your evaluation.

    Windows

    1. In the search box on the taskbar, type Control Panel and select it from the results.
    2. Select Programs > Programs and Features.
    3. Press and hold (or right-click) on the Astah System Safety and select Uninstall or Uninstall/Change. Then follow the directions on the screen on Windows.
      Uninstalling Astah System Safety

     

    Mac

    1. Locate the Astah System Safety in the Finder. Mostly you can find it in your Applications folder
    2. Drag the app to the Trash, or select the app and choose [File] – [Move to Trash].
    3. If you’re asked for a user name and password, enter the name and password of an administrator account on your Mac.
    4. To delete the Astah System Safety completely from Mac, empty your trash.
      Uninstall Astah System Safety
  • Where can I see the system requirements?
section divider

Functionality

  • Which OS does this product work with?

    Windows and Mac. Please refer to System Requirements for details.

    Currently, Linux is not supported. If you’d like to use the product on Linux, please let us know. We will consider creating a Linux version in the future.

  • Can I paste diagrams into Microsoft Word, Excel, or PowerPoint?

    Yes, you can integrate diagrams into Microsoft Office applications in two ways:

    Exporting as an Image File:

    1. Go to [File] > [Export Image] in Astah’s main menu.
    2. Export the diagram as an image file in BMP, PNG, EMF, or SVG format.
    3. Insert this image file into your Microsoft Word, Excel, or PowerPoint document.

    Copying to Clipboard:

    1. Select the model elements on the diagram in Astah.
    2. Go to [Edit] > [Copy to Clipboard] in the main menu.
    3. Paste directly into your Microsoft Word, Excel, or PowerPoint document.

    Note on Image Quality:

    • Using vector formats (EMF and SVG) is recommended for clearer images, especially when scaling, as they maintain quality better than raster formats (BMP and PNG).

    Important:

    • Please note that ungrouping images in Microsoft Word and Excel is not supported by Astah.
  • Can I export tables to Excel in Astah?

    Yes, tables can be exported to Excel in several ways.

    • For Individual Tables:
      1. Open the table.
      2. Click on the ‘Export to Excel’ button located at the upper right corner of each table.
        Export SysML Requirement Table to Excel
    • For multiple tables at once:
      To export all STAMP/STPA tables at once, navigate to [File] > [Export] > [STAMP/STPA Tables to Excel].

      Export Tables from Astah

section divider

Training and Consulting

  • Where can I find training services for using Astah products?

    We have partnered with several training and consulting companies that offer comprehensive training services for Astah products. You can find all the training partners on this page.

    For a training using Astah System Safety, there are two partner companies who provide the training courses.

    • NORASI Team
      • Essential STAMP/STPA, GSN/D-Case with Astah System Safety (This course opens in October, 2024)

      • Essential UAF with Astah UAF plugin (This course opens in October, 2024)

    • Third Exploration (Beijing) Technology Co., LTD.
      • Automated Driving Systems Safety
      • Systems Safety Analysis
      • Safety Systems Engineering

     

    These partners provide both in-person and online training sessions to help you get the most out of Astah. You can find more information about these training services on our partner page and directly contact our partners.

section divider

Troubleshooting

  • Where are the Astah log files?

    When you are asked to send log files along with your bug report, please send the 2 log files that are stored in your home directory:

    • env.log
    • trace.log

    You can find them in the USER_HOME\.astah\systemsafety\.

  • How can I increase the performance of Astah?

    The performance level of Astah System Safety depends on the RAM capacity of your machine. Please Try the following methods to improve the performance:

    1. Turn off the mouse cursor tracing option
      However, in some environments, this option may slower the drawing on the diagram.
    2. Turn the garbage collection settings of Java
      It is possible to alter the timing of garbage collection through Java’s non-standard options.

      If you are on Windows
      1. Close Astah System Safety.
      2. Open the astahsystemsafety.l4j.ini file located in Astah System Safety installation folder with a text editor.
      If you do not have permission to edit the file, please ensure to open the file as an administrator.
      3. Set the heap size, save the file and restart Astah System Safety.
      Example)
      -Xms16m
      -Xmx512m

      If you are on Mac
      1. Close Astah System Safety.
      2. Open a terminal and execute the following command.
      E.g: Example of rewriting the maximum heap size to 2048m
      defaults write com.change-vision.astahsystemsafety /com/change-vision/astahsystemsafety/ -dict-add JVMOptions/ '{ "Xmx" = "-Xmx2048m"; }'
  • Why is Astah operating slowly?

    This issue can occur when multiple diagrams/tables are open simultaneously. To enhance performance, we recommend closing those you’re not currently using. You can easily close multiple items at once: simply right-click on a diagram/table tab and select the appropriate option from the close menu.
    Diagram Close menu in Astah

    Additionally, ensure your Astah System Safety is up to date and that your system meets our recommended specifications. If the issue persists, consider restarting the software.