Licensing

section divider

Pricing and Discounts

section divider

Setup

  • How can I install Astah in silent mode?

    Yes, use the command below.


    e.g: Installing Astah UML 8.2

    astah-uml-8_2_0-66631d-jre-64bit-setup.exe /verysilent

    If you would like to install Astah to a specific directory, use /DIR option.

    astah-uml-8_2_0-66631d-jre-64bit-setup.exe /verysilent /DIR=”the destination of installataion folder

  • Where can I see the system requirements?
  • How can I change a Machine to use Astah?
    1. Make a back up files of the following on your curremt machine if you have:
      • Plugins: Userhome/.astah/uml/plugins
      • User templates:Userhome/.astah/uml/template
      • Customized system properties: Userhome/.astah/uml/JudeU.properties
      • Customized UseCase Description template: Userhome/.astah/uml/UCDescriptionProp.properties
    2. Uninstall Astah completely from the current machine
    3. Download and install Astah on new machine
    4. Restore the back up data to the new machine.
    5. Have your license file reissued and set from [Help] – [License] – [Set License Key].
  • How can I increase the performance of Astah?

    The performance level of Astah depends on the RAM capacity of your machine. Try the following methods:

    Use the latest Java environment

    Refer to the How to use a specific version of the JavaVM and use the latest version of Java.

    Turn off the mouse cursor tracing option

    In some environments, having this option on will make rendering slower.

    Tune some garbage collection settings

    When the value of INITIAL_HEAP_SIZE is set to 16m, the garbage collection does not work fully unless your computer uses more memory than 16MB.

    Use the latest version of Astah

    Download the latest version is available from Download page.

    Close Map View

    Closing the Map View could increase the performance a little. To close, go to [Tools] – [System Properties] – [Project View] and take the tick off the [Show Map View below Project View].

    Disable Content Assist and Suggest Feature

    Disabling the Content Assist (A dotted green line that appears on the diagram when you try to move and align objects with others) and Suggest Feature could increase the performance a little. To close, go to [Tools] – [System Properties] – [Diagram Editor] and take the tick off two options.
    Draw suggest

section divider

Functionalities

  • Does Astah Support Object Diagrams?

    Yes. Please create Object diagrams using the Class diagram.
    Please use [Instance Specifications] and [Link] are on the Tool Bar of Class Diagrams.

  • I copied objects but when I edit one, the change applies to the another.

    In that case, Clone the model instead of copying. A cloned model will be an independent model.

  • My Astah file does not open.

    Astah project files (.asta) are upward compatible. If project files have been edited by newer version, they cannot be opened in older version of Astah. For information about model versions, click here.

    If you cannot open project files using appropriate version of Astah, please change the stack size in the [Tools] – [System Properties] – [File].

section divider

Troubleshooting

  • My Astah file does not open.

    Astah project files (.asta) are upward compatible. If project files have been edited by newer version, they cannot be opened in older version of Astah. For information about model versions, click here.

    If you cannot open project files using appropriate version of Astah, please change the stack size in the [Tools] – [System Properties] – [File].

  • I copied objects but when I edit one, the change applies to the another.

    In that case, Clone the model instead of copying. A cloned model will be an independent model.

  • I was asked to correct invalid models. What are the invliad models and how can I correct them?

    Invalid models are broken data that were produced due to the software’s bug.
    If you were asked to correct invalid models – that means your log file indicates that your project file may contain invalid models.

    Go to [Tools] – [Correct Model] – [Correct Invalid Models] and continue by following the messages that would appear.
    Correct Invalid Models

  • How can I use a specific version of Java?

    If you have a preferred Java to use Astah, you can use it by following the instruction below. However technical support is not provided if you are using Astah on un-supported System Requirements.

    When you use un-supported Java to run Astah, you will get the alert when launching Astah. To ignore this alert,, add-nojvchk option at launch.

    Windows

    1. Have your preferred JDK installed on your PC
    2. Rename the “jre” folder in the Astah install folder to something else
    3. Astah detects the latest Java (Should be the Java you installed at step 1) in your PC and then automatically uses it to run.

    Mac

    1. Copy a “jre” folder in the JDK installation folder you prefer to use
    2. Right-click Astah App and select [Show Package Contents] from its pop-up menu
    3. Paste the “jre” folder under Contents/Plugins/JDK/Contents/Home.

    Linux

    Please refer to “How to run Astah on Linux“.

  • Where are the Astah log files?

    When you are asked to send log files along with your bug report, please send the 2 log files that are stored in your home directory:

    • astah_uml.log
    • astah.log

    You can find them in the USER_HOME\.astah\uml directory.

    Additionally, if your bug may be related to the plug-ins, please send us the log file accordingly which you can also find in the USER_HOME\.astah\uml directory.

    • C++ Reverse Plugin: cplusreverse.log
    • C# Reverse Plugin: csharpreverse.log
    • Easy Code Reverse Plugin: easycodereverse.log
    • State Transition Table: statematrix.log
    • State Transition Path: statepath.log