Download and Install Astah


Download Astah from our Download page.
If you are a student, fill the form to get a free student license.

About Java

Installers for Windows and Mac OS have required JRE included.
Linux users need to set up required Java by yourself by following the instructions.

section divider

Start Astah

You can launch Astah by:

  • Choosing [Astah] from the Start menu or
  • Double-clicking Astah’s app icon or .asta file

When launching Astah, it automatically looks for new updates through HTTP access and shows a dialogue if a newer version is available.
If you wish not to check for updates, change the option from [Tools] – [System Properties] – [Other].
Check update option

section divider

Set License

If a license is not set up yet, a license dialog appears when you launch Astah.
You can open this dialogue from [Help] – [License] anytime.
Astah License Dialogue

If you have a floating license, click [Set Floating License]. For further steps, please read the floating license guide.
If you have a non-floating license, click [Set License key] and specify your license file (.xml).
A free 20-day trial is included at the first installment. Once the first 20 days are over, please purchase a license.

section divider

Astah Interface

When you start Astah for the first time, you may get this blank screen.

But when you create a project or a diagram, all the panes will go active as below:


Astah Interface

  1. Main Menu: Lists of the basic menu
  2. Project View: Show model information in a tree and where you search and set alias…etc.
  3. Map View: View controller of the diagram view
  4. Property View: Edit detailed information of the selected model
  5. Diagram Editor: A canvas where you draw diagrams
  6. Extra View: This pane will be added after you install plug-ins that require this view such as State transition tables, M Plus…etc.
section divider

Project View

Project View provides an overview of the whole project. Tabs at the top can be used to switch the Project View between “Structure Tree”, “Hierarchy Tree”, “Inheritance Tree”, “Map”, “Diagram”, “Search”, and “Alias” views.

Structure Tree

The Structure Tree is the default view in this Project View where you can see the structure of your project in a hierarchy. You can organize diagrams and models using packages.
Astah Filter in Tree

Filter by keyword

Simply type a keyword, and hit the [Enter] key. The *, ? and camel cases are available.

Filter by type

You can filter by specifying the model type. If you want only Classes to appear in the tree, hit “type=class“.
You can also add a keyword to filter by its name too. (e.g: type=classEngine)

 Description
type=class
This shows Classes only and the following keyword works for Classes only.
type=package
This shows Packages only and the following keyword will work for package names only.
type=er
This shows [ER] package and models under the [ER] package and the following keyword will work for ER models only.
type=diagram
This shows diagrams only and the following keyword will work for diagram names.
section divider

Map View

Map View is a controller of the diagram view. The yellow rectangle indicates the area that is currently shown in the Diagram Editor.
Astah Map View

Move

You can drag the yellow rectangle to change the area you want to see on the diagram editor.

Zoom in/out

You can create a yellow rectangle by a right-drag to pinpoint where you want to see.

section divider

Hide Map View

If you do not need an independent map view, you can hide it.

  1. Go to [Tools] – [System Properties] and select [Project View] from the left menu.
  2. Unselect [Show Map view below Project view (Restarting Astah is required.)] option, click [Apply] – [OK].
    Disable Map View in Astah


  3. Restart Astah.
  4. Map View will be gone, but it can be opened from [Map] tab in the top-left pane when needed.
    Embedded Map View