Astah User's Guide

Create a project

Creating a new project file

You can create a new project file by:

  • Going to [File] - [New] or
  • Clicking the most-left icon on a Tool bar
    Create a new Astah project

Choose a pre-installed template
You can create a project by choosing a pre-installed template file.
If you want a list of classes and properties pre-installed, use this template file.

Create from Template File


Set Programming Language

Setting a programming language will enable you to add language-specific options for classes, attributes and operations. Select a project package in the tree and check Java, C# or/and C++.

Set programming language

Ticking this option enables you to add language-specific properties for Classes, Attributes and Operations shown below in the [Language] tab.

For Java

Set programming language

For C#

Set programming language

For C++

Set programming language


Creating a diagram

You can create a new diagram from [Diagram] menu.

Create a new diagram


Astah Interface

When you create a diagram, a diagram editor opens automatically on the right pane in Astah.
Basically Astah consists of 5 panes as shown below.

Astah Interface
  1. Main Menu: Lists of basic menu
  2. Project View: Show model information in tree and where you search and set alias...etc.
  3. Map View: View controller of the diagram view
  4. Property View: Edit detailed information of selected model
  5. Diagram Editor: A canvas where you draw diagrams


Auto-save files

You may want to turn on the auto-save feature as it is off by default. If you want to turn it on, switch the save icon to the auto-save one from the tool bar.
auto save .asta files

You can adjust the frequency from [Tools] - [System Properties] - [File] menu.
auto save .asta files



Basic operations you should know before you start!

You may want to turn on the auto-save feature as it is off by default. If you want to turn it on, switch the save icon to the auto-save one from the tool bar.

Create objects

There are several ways to create objects other than choosing from the tool palatte.

  1. Drag from the tree.
    Create an object

  2. Using Suggest Feature
    Click a mini icon that appears when you have mouse over an object.
    astah suggest feature
    TIPS: How to turn off the Suggest Feature!

  3. Pasting texts from Clipboard
    You can paste copied texts on a diagram to create models. First you copy the text, then you will be asked which model you want to create. After confirming, models would be created for each text.
    astah suggest feature


Create Objects in a row

There are two ways to create the same model element continously.

  1. Hold [Shift Key] down : Keep clicking on a diagram with holding [Shift] key down.
  2. Turn on the [Continuous] mode : Click the [Continuous] mode on the tool palette.
    Continuous mode

Wrap Text

You can wrap text with [SHIFT+ENTER], [ALT+ENTER] or [CTRL+ ENTER].
However you cannot wrap text for some models.


Copy Styles

You can copy and paste the style of model elements such as background color of the model element and color of texts...etc.
Copy Style